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Abstract 
Objective 
The main goal of the needs assessment was to determine opportunities for improvement of existing 
accessibility resources, training, and services. The long-term objectives for this project include: 
consistent enforcement of accessibility requirements across multiple testers and units; novice testers 
solve the main issues quickly and build skills over time; more clarity around accessibility requirements 
for new authors; saved time for authors and accessibility testers; increased levels of accessibility across 
NLM products, alignment with DEIA and CX initiatives. 

Methods 
The project consisted of three stages: a survey, two focus groups, and prototype development of an 
interactive PDF accessibility checklist. The survey was conducted using Qualtrics, had 15 questions, and 
had 47 respondents at a 37% response rate. The focus groups had 5 participants each and were 
conducted over Zoom and MURAL. Recruitment took place over email through the OpenText TeamSite 
license-holder list and the Web and Information Management Unit’s list of Library Operations product 
owners. The checklist prototype was developed in Microsoft Word using the HHS PDF accessibility 
compliance checklist as a starting point supplemented by additional research using W3C, WebAIM, 
Adobe, Tagged PDF, and Level Access websites. 

Results 
The survey and focus groups revealed that NLM and NIH trainings and colleagues were the most utilized 
sources of information about accessibility. There was relatively low awareness of the NLM accessibility 
compliance and testing wiki and HHS accessibility resources, however the survey respondents who had 
used the HHS accessibility checklists found them useful. The main barriers NLM staff reported around 
accessibility were: difficulty keeping up with changing requirements, not knowing what tools to use, not 
knowing who to ask for support, lack of clear governance, lack of high level statement and positive 
messaging, resistance or lack of awareness among colleagues, lack of specific guidance, and complexity 
of PDF accessibility. The main suggestions for improvements in accessibility support centered around: 
tools, guidance, trainings, guides, workflows, staff support, culture change, and peer or expert review. 

Conclusion 
The following recommendations are based on the results of the needs assessment:  

1. Promote a culture change around prioritizing accessibility at NLM. 
2. Develop NLM trainings around accessibility. 
3. Increase awareness around existing NLM, NIH, and HHS accessibility resources. 
4. Provide more clear guidance on which tools staff should use for specific accessibility testing and 

remediation tasks.  
5. Develop additional guidance and resources around understanding and solving accessibility 

issues.  
6. Clarify the governance around accessibility and make that information easy to find. 
7. Designate contacts that staff can go to with questions on specific accessibility areas or to 

request trainings. 
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8. Revisit and investigate additional suggestions that survey and focus group participants shared 
after the highest priority issues are addressed. 

Introduction 
NLM sites host over 10,000 PDFs, many of which do not meet Section 508 accessibility standards. Many 
NLM staff producing PDF documents are not accessibility experts, and nearly all PDFs require additional 
work to make them accessible. The HHS accessibility testing checklists were written for expert 
accessibility testers, which likely presents a barrier to use by the majority of NLM staff who create or are 
responsible for PDF files posted to the web. While Dan suspected that a more detailed and interactive 
version of the checklist would be useful to NLM staff responsible for PDF accessibility, there has not 
been research into accessibility-related needs of NLM web contributors or product owners. Therefore 
this project began with a needs assessment to validate these assumptions and discover other 
opportunities for supporting NLM staff with their digital accessibility efforts. 

The main goal of the needs assessment was to determine opportunities for improvement of existing 
accessibility resources, training, and services. 

The long-term objectives for this project include: 

• Consistent enforcement of accessibility requirements across multiple testers and units 
• Novice testers solve the main issues quickly and build skills over time 
• More clarity around accessibility requirements for new authors 
• Saved time for authors and accessibility testers 
• Increased levels of accessibility across NLM products, alignment with DEIA and CX initiatives 

Methodology 
This project consisted of three stages: a survey, two focus groups, and a prototype of an 
interactive PDF checklist. 
Survey 
The survey was developed using Qualtrics with the goal to answer the following research questions: 

1. What are the current practices (tools, resources) around ensuring web accessibility at NLM? 
2. What barriers do web contributors and product owners face in ensuring web accessibility of 

their products? What improvements can we make to reduce these barriers? 
3. How useful are the HHS Excel-based accessibility compliance checklists? What would make them 

more useful? 

A draft of the survey was pilot tested with seven NLM staff, suggested by Dan as people representing a 
variety of experiences around accessibility. The survey was modified based on their feedback. 
Additionally, Guanfeng Song was consulted on the design of the survey and focus groups. The final 
version of the survey was sent to 127 web contributors and product owners across NLM, combined from 
the OpenText TeamSite license-holder list and the Web and Information Management Unit’s list of 
Library Operations product owners. 47 people responded to the survey, resulting in a 37% response 
rate. Due to restrictions on surveying contractors, the survey was sent only to federal staff and 
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contractors were excluded from taking the survey through an initial screening question. The full list of 
questions can be found in Appendix A. Analysis and visualizations were conducted using Qualtrics. 

Focus Groups 
Focus group participants were recruited using the same email list as the survey. A total of 11 people 
expressed interest by filling out a short sign-up screening form, though one person who signed up was 
not able to attend. Approximately half of the people who filled out the sign-up form reported having 
experience using the HHS accessibility checklists, so the focus groups were split based on this question 
to allow for a deeper investigation of staff experiences with the checklists. Focus groups were conducted 
using Zoom and MURAL. 

The focus groups were designed to answer the following research questions: 

1. What resources and tools around accessibility do NLM staff find most helpful? What is helpful 
about them? 

2. What are the biggest barriers NLM staff in ensuring the web accessibility of their products? 
What strategies would be helpful to address these barriers? 

3. How are NLM staff using the HHS Excel-based accessibility compliance checklists? What are the 
pain points, limitations, and barriers of these checklists?  

Each focus group consisted of two parts: 1. Discussion questions and 2. Brainstorming of possible 
improvements using a MURAL board. The focus group agenda can be found in Appendix B.  

Interactive PDF Accessibility Checklist 
A prototype of an interactive PDF checklist (Appendix E) was created to address the barriers that survey 
and focus group participants reported around using the HHS accessibility checklists. PDF accessibility 
was chosen as an initial focus area because many focus group participants described testing and 
remediating PDFs as being particularly complex and cumbersome. This prototype lays the content and 
foundation for an interactive checklist that can be implemented in HTML. The checklist was created by 
using the HHS PDF Accessibility Checklist as a foundation, with the addition of instructions and notes 
around testing, solving, and understanding each issue as well as reformatting to prioritize the most 
common and impactful accessibility issues and allow users to easily select only those areas that are 
relevant to the document they are evaluating. A variety of additional sources, including the W3C, 
WebAIM, Adobe, Tagged PDF, and Level Access were consulted and referenced in the creation of the 
checklist. 

Results 
Survey 

Participants 
A total of 47 people responded to the survey, out of 127 who were emailed. We did not collect 
demographic or division data to ensure anonymity, given the small size of the population surveyed. 
Approximately half of respondents were product team members/web contributors, followed closely by 
product owners-managers. Several participants filled in “other” responses for role, including 

https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/hhs.gov/web/section-508/accessibility-checklists/index.html
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“researcher”, “project or team lead”, “Section 508 coordinator”, “writer/editor”, “librarian”, “product 
consultant”, “unit head”. Only two participants selected “software engineer/front-end designer”. (Figure 
1). 

 

Figure 1 - What is your role? 

Approximately half of respondents reported testing/analyzing content for accessibility as part of their 
jobs. Making recommendations for accessibility fixes was also a commonly performed job function. 
Training or assisting staff, evaluating staff accessibility efforts, and developing guidelines and standards 
were moderately common. Few respondents reported on accessibility-related accomplishments or 
created accessibility management plans. “Other” write-in responses included: “conducting technical 
evaluations”, “representing NLM at NIH accessibility meetings”, “creating accessible web pages”, and 
acquisitions related tasks. (Figure 2) 
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Figure 2 - What accessibility-related function(s) do you perform as part of your job? 

Current Accessibility Practices 
Among the respondents who reported testing or analyzing content for accessibility, the majority 
reported analyzing HTML content, followed by PDF files. “Other” write-in responses included: social 
media, online meetings, digital content and applications, databases, and legacy computer content 
(Figure 3). Microsoft Office Accessibility Checker and WAVE were the most commonly used tools, 
followed by Adobe Acrobat Pro. “Other” write-in responses included: JAWS, Narrator, “manual 
examination”, and “other downloads and offline services” (Figure 4). Respondents reported a range of 
PDF output from their product team from none to 50-99 in the last three years, with 10-19 being most 
common (Figure 5). For those from teams that have posted at least one PDF in the last three years, the 
majority reported the PDFs being created from Microsoft Word, with print to PDF and Microsoft 
PowerPoint also being fairly common but inDesign and other methods being rare. Many respondents 
reported that they didn’t know how the PDFs were created. “Other” write-in responses included: Adobe 
Acrobat Pro and NLM collection material (Figure 6) 



7 
 

 

Figure 3 - What kind of content do you test/analyze for accessibility as part of your job? 

 

Figure 4 - What tool(s) do you use for testing, analyzing, and/or remediating documents and websites? 
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Figure 5 - Approximately how many PDFs has your product team posted for customer use in the last 3 years? 

 

Figure 6 - What method(s) does your product team use to create PDFs? 

The most frequent source of information about accessibility was NIH or NLM training, followed closely 
by working with a colleague. Other government and online resources were less common but still fairly 
popular, such as Section508.gov, web-browser tools, HHS accessibility resources, the NLM Accessibility 
Testing and Compliance wiki, and the W3C/WAI. Digital.gov, WebAIM, Deque, and LinkedInLearning 
were not commonly used. “Other” write-in responses included: “a different federal agency”, “sponsored 
classes with Adobe and others”. (Figure 7). These responses indicate that NIH and NLM training is one of 
the most effective methods for reaching NLM staff interested and engaged in accessibility work, so an 
expansion of NIH/ NLM training efforts would likely have a large impact on accessibility awareness. 
Fostering networks of collaboration around accessibility can also effectively reach and support staff in 
learning about and implementing accessibility. Only 34% of participants who answered this question 
reported using the NLM Accessibility wiki and only 37% reported using HHS accessibility resources to 
learn about accessibility, which suggests a low awareness of these resources among NLM web 
contributors and product owners. 
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Figure 7 - How have you learned about accessibility in the past? 

HHS Checklists 
Only 24% of survey respondents reported having used the HHS accessibility compliance checklists 
(Figure 8). However, among those who had used the checklists, 89% found them to be very useful and 
the remaining 11% found them to be moderately useful. (Figure 9). This data backs up the lack of 
awareness of HHS accessibility resources found in Figure 7 and suggests that expanding awareness of 
these resources could be useful for other staff in their accessibility work.  

 
Figure 8 - Have you used one or more of HHS's Excel-based accessibility compliance checklists? 
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Figure 9 - How useful were the HHS Excel-based accessibility compliance checklists? 

Words such as “simplify”, “clarify”, “applied”, “easy”, “guidelines”, and “workflow” were commonly 
used in open-ended responses to “What is useful about these HHS checklists?” (Figure 10). In open-
ended responses to “What is NOT useful about these HHS checklists?”, respondents frequently used 
words such as “link”, “irrelevant”, “cumbersome”, “overwhelming”, “difficult”, “complicated”, and 
“skip” (Figure 11). These wordclouds suggest that the checklists were valued as a relatively simple way 
to apply accessibility guidelines in a consistent workflow, but respondents faced challenges around the 
layout and structure of the Excel-based checklists being cumbersome and presenting a lot of 
complicated and irrelevant information. This is backed up in a more in-depth analysis of these 
responses. Several participants valued the thorough list of requirements that the checklists present, 
with one stating that “They give me a sense of security that I'm not forgetting anything.” However, 
several respondents also mentioned barriers around lack of information on how to solve accessibility 
issues, difficulty sifting through irrelevant information, and lack of links to the WCAG criteria for more 
detailed information about the issues (Appendix C). 

 
Figure 10 - What is useful about these HHS checklists? 
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Figure 11 - What is NOT useful about these HHS checklists? 

Barriers 
The three main challenges survey respondents reported were: 

• Difficulty keeping up with changing requirements 
• Not knowing what tools to use 
• Not knowing who to ask for support 

Relatively few respondents reported facing barriers around not knowing how to use tools, lack of 
motivation from people they work with, or the process being too time consuming. “Other” write-in 
responses included: lack of training, forgetfulness, “lack of a tool for automated ongoing review”, “lack 
of understanding by presenters and content developers that accessibility should be a consideration from 
the very beginning”, accessibility not being a high priority or part of current duties, “other staff follow-
up”, and “range of reactions, caveats, and disinterest.” (Figure 12) 
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Figure 12 - What barriers do you face in improving the accessibility of your products? 

Support 
In addition to general terms like “accessible”, “web”, and “compliance”, terms like “tool”, “checklist”, 
“workflow”, “template”, “training”, “guidance”, “simple”, and “clear” were among the most commonly 
occurring in the open-ended free text responses to the question “What accessibility skills, procedures, 
or other help would make your future accessibility work easier?”  (Figure 13). 

 

Figure 13 - What accessibility skills, procedures, or other help would make your future accessibility work easier? 

This focus on technical support and guidance was backed up in a more in-depth analysis of these 
responses. Six respondents mentioned tools, including web scanning/ monthly reports, enterprise-wide 
access to tools, a site license for JAWS, guidance on which tools to use, and a database listing potential 
tool options. Five respondents mentioned more clear guidance on issues such as requirements, tools, 
and solutions, with an emphasis that the guidance should be concrete and specific. For example, one 
respondent wrote that it would be helpful to have “Someone we can ask for help that won't refer us to a 
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web page that we've already seen and can't interpret or apply with confidence.” Trainings, guides, 
workflows, and staff support were each mentioned four times. With trainings, respondents shared that 
the trainings would be most helpful if they were regularly scheduled, with one respondent writing that 
“There is SO MUCH out there on accessibility and it would be good to schedule a 'time out' from regular 
work to catch up.” Workflow integration was a common theme, with one respondent writing that 
“Accessibility should be built into the process flow for adding or editing content to a webpage. Instead, 
it's often treated as an afterthought” and another pointing out that this retrofitting approach to 
accessibility ends up costing more as contractors later need to be hired to test for and fix accessibility 
issues that could have been avoided. Requested staff support included an “identified in-house 
specialist”, “Friendly identified authority and governance individual", and a "Centralized place at NIH 
that performs this work for all ICs." Other less commonly mentioned suggestions included information 
on NLM specific resources and products, templates, reminders, reports, culture change, feedback from 
disabled users, and examples of accessible documents and websites. 

Focus Groups 

Participants 
The first focus group included participants from the Office of Engagement and Training, Office of 
Communications & Public Liason, Public Services Division, and Lister Hill. Four out of five participants 
described their level of experience with digital accessibility as “beginner” and one as “advanced”. 
“Testing/Analyzing content for accessibility” was the most frequently reported job function, followed by 
“Making recommendations for accessibility fixes” and “Training and assisting staff in accessibility.” 

The second focus group included participants from the Technical Services Division, the Office of 
Engagement and Training, History of Medicine Division, the History of Medicine Division, and Lister Hill. 
Two out of five participants described their level of experience as “beginner” and three as 
“intermediate.” “Testing/Analyzing content for accessibility” was the most frequently reported job 
function, followed by “Making recommendations for accessibility fixes.” 

Current Practices 
Participants mentioned learning about accessibility from a presentation by the US Access Board, OET 
accessibility workshop webinar series, Drupal GovCon, CIDI series, Section508.gov, Digital.gov, 
Usability.gov, W3C, WebAIM, HHS checklists, tools built into software (e.g. Microsoft and Adobe 
accessibility checkers), browser tools such as ANDI and axe, and colleagues. Some participants also 
consulted various online sources, which were described as being “hit or miss”. One participant shared, 
“If there’s anything in-house, haven’t discovered it,” supporting the survey finding that there is low 
awareness of NLM, NIH, and HHS accessibility resources. 

HHS Accessibility Checklists 
Participants in the second group, all of whom reported having experience with the HHS accessibility 
checklists in the screening survey, were asked what they found helpful and not helpful about the 
checklists. The most helpful things about the checklists included their comprehensiveness, being tied 
closely to the Section 508 law, and the report format that makes it easy to share findings. One 
participant found the comprehensiveness comforting, since they know that if they go through the 
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checklist they will catch any possible Section 508 violation. Another appreciated the reminders of areas 
of accessibility that they tend to neglect such as sensory characteristics and said that they primarily use 
the checklists when evaluating a new format they hadn’t worked with recently. The checklists were also 
described as being useful tools to explain the accessibility issues and justify the effort to fix them when 
speaking with content creators or supervisors. The main frustrations with the checklists revolved around 
lack of guidance on solutions and better understanding the issues. One participant said that they prefer 
to use tools that can guide them built into the software they’re already using and found it difficult to 
understand the checklists without assistance. 

Communication 
When asked how participants would want to hear about a new accessibility resource that becomes 
available, the wiki and emails from the web contributors listserv were the most popular responses. 
However, one participant mentioned that they are not subscribed to the wiki page so they may not see 
changes, and another participant mentioned that emails may get lost in a crowded inbox. Word of 
mouth from colleagues was also mentioned as a potential source. These responses suggest that a multi-
pronged communication strategy relying on emails, wiki updates, and word of mouth would be most 
effective. 

Challenges 
The main challenges participants identified included: lack of clear governance, lack of high level 
statement and positive messaging, resistance or lack of awareness among colleagues, lack of specific 
guidance, and complexity of PDF accessibility. Several participants brought up concerns around 
navigating bureaucracy, such as not knowing the proper channels for filtering feedback on accessibility 
issues, who is responsible for making decisions around accessibility, and especially around how much 
authority staff have when working with inherited content they didn’t create, relying on third-party 
developers or platforms, and facilitating events with external presenters who may not be informed 
about accessibility. Similarly, one participant brought up that they didn’t know whose job it was at NLM 
to conduct trainings and whether that is something they could request for their program or division.  

Cultural and social issues were also discussed at length in the focus groups. Some participants discussed 
the desire for a more high-level statement of commitment to accessibility rather than content that 
exclusively focuses on technical details and checklists, as well as a more joyful and affirmative approach 
to discussing accessibility. Relatedly, several participants mentioned lack of awareness or commitment 
to accessibility among colleagues as a major barrier – while many people at NLM know about Section 
508, there is not a lot of awareness on how to actually achieve Section 508 compliance and accessibility 
is often not seen as a priority. Some staff had encountered considerable reluctance to improve 
accessibility and misconceptions that accessibility is too complicated, requiring them to spend time 
justifying the efforts rather than actually working on improving accessibility.  

On the technical side, lack of specific guidance, especially around audio descriptions and captions, was 
identified as a major barrier. A lot of details on accessibility implementation are left up to individual 
contributors, who do not always feel equipped to make those judgment calls on their own. Lack of 
guidance on which specific tools to use also presented challenges, as did lack of assistance with 
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interpreting issues identified by tools such as SEO spiders. Several participants described PDF files in 
particular as being very complex and difficult to work with, as there is not a lot of guidance on the 
accessibility of complex PDFs, software such as Adobe is cumbersome to use, and PDFs are often used 
when the content would be better presented as HTML on a web page. 

Support 
Focus group participants were asked to brainstorm potential improvements to accessibility at NLM on a 
MURAL board and vote for their favorite three. The top four suggestions for improved accessibility 
support, which received at least three votes, included: 

1. A peer or expert review process for accessibility evaluations 
2. A high-level positive statement about accessibility 
3. Change NLM culture so accessibility is a priority 
4. A staff person appointed for each kind of accessibility format/ area (e.g. video, social media) 

Other suggestions that received at least one vote included: IDEA council focus on staff accessibility 
needs, an NLM 508 working group or community of practice (COP), designated person authorized to sign 
off on products, small team or designated contact to go to with questions, incorporating accessibility 
into more discussions, accessible page templates, defining page owners across the website so it’s easy 
to find the right point of contact, more consistent guidance for captioning and audio description, better 
and more positive promotion of accessibility, and gold standard examples. There were over 50 other 
suggestions that did not receive votes – these are presented in Appendix D. 

Discussion 
Survey respondents focused more on technical support whereas focus groups participants prioritized 
culture change. This divergence may be due to differences between participants and/or the questions 
and structure of the survey vs the focus groups. The survey was primarily close-ended with only a small 
number of open-ended questions and most of the questions were focused on technical accessibility 
methods and experiences, whereas the focus group allowed the participants to talk in more depth about 
their experiences and challenges and connect with other participants, which may have predisposed 
focus group participants to take a broader and more socially oriented perspective. 

Many of the results, particularly around technical challenges and experiences with the HHS accessibility 
checklists, confirmed our assumptions about the kind of technical resources that would be helpful in 
promoting accessibility of NLM web products. A relatively low awareness of NLM and HHS resources 
such as the NLM accessibility wiki and the HHS accessibility compliance checklists was surprising and 
point to a need to promote existing resources in addition to developing new ones. The popularity of 
NLM and NIH trainings and conversations with colleagues was also surprising, especially given a 
relatively low number of such trainings in recent years and lack of formalized community of practice 
around accessibility at NLM. These results suggest that expansion of training and accessibility 
community efforts at NLM would have a major impact on awareness and capacity around digital 
accessibility among NLM staff. 
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Our approach to this needs assessment has several limitations. Although the response rate to the survey 
was fairly high, the sample sizes for the survey and especially for the focus groups were still relatively 
small. In addition, people who were most committed and interested in accessibility were more likely to 
respond to the survey and/or sign up for the focus groups, potentially resulting in a non-response bias. 
These results thus may not be fully representative of the experiences and needs of all NLM staff who do 
work around digital accessibility. However, they represent the perspectives of the staff who are most 
likely to use new resources, attend trainings, or take part in initiatives, so the results are still useful 
when deciding which approaches to prioritize. In the future, a mandatory survey or a survey that 
includes accessibility as part of a broader set of questions may yield more information about the needs, 
experiences, and perspectives of staff who may be less knowledgeable or interested in accessibility 
topics. Social desirability bias may also have impacted the study results. The survey was fully anonymous 
and avoided asking participants to rate their expertise or level of familiarity with accessibility to 
counteract this potential bias. The results from the focus groups have also been anonymized, but the 
risk of social desirability bias is greater since some of the participants knew each other and had worked 
together. 

Recommendations 
 

1. Promote a culture change around prioritizing accessibility at NLM. This can include: 
• A high-level and positive statement about NLM’s commitment to accessibility that is easy to 

find on the NLM wiki and/or website. 
• Integration of accessibility into the work of existing Diversity, Equity, and Inclusion efforts 

such as the IDEA council. 
• Creation of a working group or community of practice to allow NLM staff working on 

accessibility to connect with one another. A Microsoft Teams forum could serve as a first 
step. 

2. Develop NLM trainings around accessibility, as many NLM staff rely on NLM/ NIH trainings as 
their main source of information around accessibility. 

3. Increase awareness around existing NLM, NIH, and HHS accessibility resources, including the 
NLM Accessibility wiki and the HHS checklists. Emails about new and existing resources and 
greater visibility for the wiki by linking with the NLM At Work wiki could be effective strategies. 

4. Provide more clear guidance on which tools staff should use for specific accessibility testing and 
remediation tasks. Enterprise-wide standardized tools and regular accessibility scanning would 
be particularly valuable. 

5. Develop additional guidance and resources around understanding and solving accessibility 
issues. The interactive PDF checklist (Appendix E) can be used as a model for additional 
resources around other formats such as HTML, audio, and video. The checklist needs to be 
converted into HTML and should be user tested with a few volunteers to ensure that it is 
understandable and effective. Other resources such as templates and gold standard examples 
would also be useful. 

6. Clarify the governance around accessibility and make that information easy to find – who is 
responsible for making decisions and ensuring accessibility in each unit or area? 

7. Designate contacts that staff can go to with questions on specific accessibility areas or to 
request trainings. 
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8. Revisit and investigate additional suggestions that survey and focus group participants shared 
after the highest priority issues are addressed. 

 

Appendices 
 
Appendix A: Survey Questions 
Thank you for your willingness to provide feedback about your experience supporting web accessibility 
at NLM. Your responses will be valuable in helping the Public Services Division understand practices and 
barriers to web accessibility implementation at NLM in order to improve our trainings, resources, and 
services.  
 
You are eligible to participate in this survey if you are a federal NLM employee and web accessibility is 
part of your work. Your participation is voluntary and you may leave the survey at any time. The survey 
should take no more than 10 minutes to complete.  
 
Your responses to this survey are anonymous and no personally identifiable information (PII) will be 
collected (unless you enter PII into open-ended response questions). All data and results that are 
reported or shared will be anonymous and cannot be connected to you.  
 
If you have any questions about this survey, please contact Luke Kudryashov 
(luke.kudryashov@nih.gov). 

1. Are you a... 

o Federal employee  

o Contractor  
 

2. What is your role? (Select all that apply) 

▢ Product owner-manager (a person in charge of daily management of web pages)  

▢ Product team member (a web contributor who helps maintain web pages)  

▢ Software engineer / Front-end designer  
Other (please specify) 
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3. What accessibility-related function(s) do you perform as part of your job? (Select all that apply) 

▢ Testing/ Analyzing content for accessibility  

▢ Making recommendations for accessibility fixes  

▢ Creating accessibility management plans  

▢ Developing guidelines and standards regarding accessibility implementation  

▢ Evaluating a staff person's accessibility effort  

▢ Reporting on accessibility-related accomplishments in weekly or quarterly reports  

▢ Training or assisting staff in accessibility  

▢ ⊗None of the above  
Other (please specify) 

4. What kind of content do you test/ analyze for accessibility as part of your job? 

▢ HTML content (web pages)  

▢ MS Word files  

▢ MS PowerPoint files  

▢ PDFs  

▢ Video/ audio  
Other (please specify) 
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5. Have you used one or more of HHS's Excel-based accessibility compliance checklists (link opens in a 
new window)? 

o Yes  

o No  
 

6. How useful were the HHS Excel-based accessibility compliance checklists (link opens in a new 
window)? 

o Not at all useful  

o Slightly useful  

o Moderately useful  

o Very useful  

o Extremely useful  
 

https://www.hhs.gov/web/section-508/accessibility-checklists/index.html
https://www.hhs.gov/web/section-508/accessibility-checklists/index.html
https://www.hhs.gov/web/section-508/accessibility-checklists/index.html
https://www.hhs.gov/web/section-508/accessibility-checklists/index.html
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7. What is useful about these HHS checklists? (If you wish to comment) 

8. What is NOT useful about these HHS checklists? (If you wish to comment) 

9. How have you learned about accessibility in the past? (Select all that apply) 

▢ HHS accessibility resources  

▢ NLM Accessibility Testing and Compliance wiki  

▢ NIH or NLM training  

▢ LinkedinLearning training  

▢ Section508.gov  

▢ Digital.gov  

▢ W3C / WAI  

▢ WebAIM  

▢ Deque.com  

▢ Used web-browser tools such as WAVE, ANDI, axe  

▢ Worked with a colleague  

▢ ⊗None of the above  
Other (please specify) 
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10. What barriers do you face in improving the accessibility of your products? (Select all that apply) 

▢ Process is too time consuming  

▢ Don't know what tools to use  

▢ Know the tools but don't know how to use them  

▢ Technical requirements are difficult to understand or interpret  

▢ Difficult to keep up with changing requirements  

▢ Don't know who to ask for support  

▢ Lack of motivation from people I work with  
Other (please specify) 

11. What accessibility skills, procedures, or other help would make your future accessibility work easier? 

12. Approximately how many PDFs has your product team posted for customer use in the past 3 years? 

o none  

o 1-4  

o 5-9  

o 10-19  

o 20-49  

o 50-99  

o 100 or more  
I don't know 
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13. What method(s) does your product team use to create PDFs? (Select all that apply) 

▢ Save as PDF from Word  

▢ Save as PDF from PowerPoint  

▢ Print to PDF  

▢ InDesign  

▢ Automated with a programming language  

▢ Other (please specify) ________________________________________________ 
⊗I don't know 

14. What tool(s) do you use for testing, analyzing, and/or remediating documents or web content for 
accessibility? (Select all that apply) 

▢ Microsoft Office Accessibility Checker  

▢ Adobe Acrobat Pro  

▢ WAVE  

▢ axe  

▢ ANDI  

▢ Browser developer tools  
Other (please specify) 

15. Is there anything else you would like to share about your work with accessibility at NLM? 

Appendix B: Focus Group Agenda 

Part 1. Discussion 

1. Introductions: please share your name, pronouns if you would like, your division, what kind of 
accessibility related work you do, and why you were interested in participating in the focus group. 
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2. What tools, resources, trainings, etc. have you used to learn about accessibility? What has been 
most helpful and why? 

3. What challenges do you face in your accessibility work? 
4. What kind of support would help you be more effective and/or efficient with the accessibility work 

that you do? 
or: 
In the future, a new resource is posted to section508.gov. How would you like to hear about this new 
resource? (How would you like accessibility information to flow to you?) 

Part 2. Exercise: Block out an information resource package 

1. Brainstorm ideas that would help NLM staff, regarding accessibility supports and resources. 
2. Discussion and ratings (each participant gets 3 votes). 

Appendix C: Survey Free Text Summaries 

Suggestions from Survey 
From responses to “What accessibility skills, procedures, or other help would make your future 
accessibility work easier?” and “Is there anything else you would like to share about your work with 
accessibility at NLM?” 

Suggestion Count Comments 

Tools 6 "I would like a replacement tool since Accenture/Deque tool isn't 
available. I had appreciate the monthly reports we used to 
receive.", "Clear guidance on requirements and which tools to 
use.", "an online resource/database that lists each tool, what it 
does, and how to link to the tool, perhaps any training available for 
that tool.", "Several potentially useful products have been 
suggested, but not purchased... money better spent 
elsewhere.  Policy is not actively campaigned, or supported 
financially.  While there was some clear thresholds once at the HHS 
level, these were abandoned with a failed replacement of the 
Accenture web scanning solution, and were not addressed further 
during the Trump administration.  Current HHS guidance is not 
firm, and action, such as hosting a scanning solution, is not fully 
supported centrally.", "Enterprise wide access to 
tools/resources/support for accessibility compliance", "If a site 
license for JAWS could be worked out, my whole team could use 
that instead of Windows Narrator, which is not as good." 

Guidance 5 "Clear guidance on requirements and which tools to use.  Someone 
we can ask for help that won't refer us to a web page that we've 
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Suggestion Count Comments 

already seen and can't interpret or apply with confidence.", 
"Friendly identified authority and governance individual familiar 
with my products who monitors changing requirements, identifies 
actions needed, and demonstrates new testing and corrections.", 
"Concrete guidance and solutions/exemplars. Guidance is often 
general and not specific.", "Policy is not actively campaigned, or 
supported financially.  While there was some clear thresholds once 
at the HHS level, these were abandoned with a failed replacement 
of the Accenture web scanning solution, and were not addressed 
further during the Trump administration.  Current HHS guidance is 
not firm, and action, such as hosting a scanning solution, is not fully 
supported centrally.", "It would make it easier to focus on what 
needs to be reviewed/changed if we all had a common HHS 
defined checklist. In years past, we used an Accenture checklist 
which was nice since it compared web pages against a 
defined/approved set of criteria and helped us work towards a 
common goal. Having this checklist helped to remove some of the 
uncertainties regarding reviewing pages/files for accessibility 
issues." 

Trainings 4 "Explored some resources once, but I'd like more training or 
reminders to easy tutorials/guidelines for creating web pages & 
tutorials.", "brief training courses to learn & help retain 
information & learn a useful workflow", "Maybe a group meeting 
that trains folks once a month on different things.", "It would be 
nice to have a regular, scheduled but brief workshop, maybe on an 
annual basis, to present those of us with responsibilities in this 
area with the latest tools and techniques. There is SO MUCH out 
there on accessibility and it would be good to schedule a 'time out' 
from regular work to catch up. Honestly, this should probably be 
required HHS training for content developers but I'm not going to 
be the one to suggest that. ;-)" 

Guides 4 "Explored some resources once, but I'd like more training or 
reminders to easy tutorials/guidelines for creating web pages & 
tutorials.", "Easy to follow checklists, tutorials, guides on how to 
make materials accessible to be used as reference sheets until this 
becomes a "routine" part of my workflow.", "an online 
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Suggestion Count Comments 

resource/database that lists each tool, what it does, and how to 
link to the tool, perhaps any training available for that tool.", "It 
would make it easier to focus on what needs to be 
reviewed/changed if we all had a common HHS defined checklist. 
In years past, we used an Accenture checklist which was nice since 
it compared web pages against a defined/approved set of criteria 
and helped us work towards a common goal. Having this checklist 
helped to remove some of the uncertainties regarding reviewing 
pages/files for accessibility issues." 

Workflows 4 "Accessibility should be built into the process flow for adding or 
editing content to a webpage. Instead, it's often treated as an 
afterthought.", "They will also spend money for contractors to 
check 508 compliance, when it's totally unnecessary. It should just 
be part of normal workflow.", "brief training courses to learn & 
help retain information & learn a useful workflow", "Integration 
into the normal development/maintenance of products instead of 
an after fact." 

Staff support 4 "identified in-house specialist available for support in making 
complex PDF files accessible (including forms, graphics, and tables). 
Friendly identified authority and governance individual familiar 
with my products who monitors changing requirements, identifies 
actions needed, and demonstrates new testing and corrections. ", 
"Someone we can ask for help that won't refer us to a web page 
that we've already seen and can't interpret or apply with 
confidence.", "Enterprise wide access to tools/resources/support 
for accessibility compliance", "Centralized place at NIH that 
performs this work for all ICs" 

Information on 
NLM specific 
resources/ 
products 

2 "it's unclear whether following microsoft accessibility prompts will 
produce a completely 508-compliant document.  Are all NLM 
templates (O365, web) already set for compliance? knowing these 
answers would help.", "A better understanding of NLM's 
accessibility resources and how they can be applied to specific NLM 
products. To be fair, this isn't something that I've sought out so if it 
does already exist, maybe it just needs to be more visible or 
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Suggestion Count Comments 

communicated directly to those working with accessibility on NLM 
products." 

Templates 2 "I think the most effective tools are templates. Whenever I can use 
or build an NLM template for something, a lot of the accessibility 
work is done in the template. I can build accessibility into my 
routines much more easily when I'm using standard formats. I "get" 
that people want to be creative, but often simple is better.", "it's 
unclear whether following microsoft accessibility prompts will 
produce a completely 508-compliant document.  Are all NLM 
templates (O365, web) already set for compliance? knowing these 
answers would help." 

Reminders 2 "Reminders to make public materials accessible", "Explored some 
resources once, but I'd like more training or reminders to easy 
tutorials/guidelines for creating web pages & tutorials." 

Reports 1 "I would like a replacement tool since Accenture/Deque tool isn't 
available. I had appreciate the monthly reports we used to 
receive." 

Understanding/ 
culture change 

1 "It would be helpful if my supervisors/other leaders understood 
that these are not difficult or onerous requirements. I think they 
worry too much about 508 compliance and it's much simpler than 
they think it is. I truly spend more time having to convince others 
that their suggestions are in line with 508 than actually working to 
achieve 508 compliance. They will also spend money for 
contractors to check 508 compliance, when it's totally unnecessary. 
It should just be part of normal workflow." 

Feedback from 
disabled users 

1 "Simpler process for getting feedback from disabled users on how 
we can improve our efforts." 

Examples 1 "Concrete guidance and solutions/exemplars. Guidance is often 
general and not specific." 
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HHS Checklists 
From responses to “What is useful about these HHS checklists? (If you wish to comment)” and “What is 
NOT useful about these HHS checklists? (If you wish to comment)” 

Useful 

Concept Count Comments 

Thorough list of 
requirements 

3 " all the info you can want is available, should you wish to refer to 
it.", "They give me a sense of security that I'm not forgetting 
anything." 

Possible break 
points 

1 
 

Simplify workflow 1 "They help make it easier to understand the accessibility guidelines 
by simplifying the process through utilizing a checklist style 
workflow." 

Clarity 1 "They clarify the rules being applied (i.e., what is needed for the 
document to be accessible.)" 

Making notes 1 "Nice to have a checklist that you can download and review for 
specific files to review. You can then make notes on the 
spreadsheet." 

Not Useful 

Concept Count Comments 

Too much 
irrelevant info - 
overwhelming 

2 "all the info you can want is available -- which can be overwhelming, 
and some of it is not immediately useful", "There are an awful lot of 
elements included that we don't use in our files, so sometimes going 
through them I worry that I'm skimming too much to skip over the 
stuff that is irrelevant to me. I'm not sure if this can be avoided, 
though. " 

No links to WCAG 2 "It would be nice if the WCAG Ref#'s were linked to the actual WCAG 
web page referenced.", "These checklists could link out to , for 
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instance, the WCAG user support guide for each element that helps 
understand _how_ to remedy the fault…" 

Complicated, 
cumbersome 

1 "Since the guideline themselves are a bit complicated, the resulting 
checklist can be somewhat cumbersome to deal with." 

Spreadsheet 
layout 

1 "Being a spreadsheet, the checklists are a little difficult to understand 
at first until you get used to the layout" 

 

Barriers 
From “Other” write-in responses to “What barriers do you face in improving the accessibility of your 
products? (Select all that apply)” 

Barrier Count Comments 

Accessibility not 
priority for org/ 
others 

5 "accessibility isnt as high of a priory", "Lack of understanding by 
presenters and content developers that accessibility should be a 
consideration from the very beginning. We're working on this!", 
"range of reactions, caveats, and disinterest", "I also don't feel like I 
have equivalent colleagues who do the same work and could be a 
resource.", "I have noticed that leadership does not always achieve 
accessibility. For example, I receive emails from LO leadership that do 
not seem to be 508 compliant (for example -- photos are not tagged, 
and key information is only available in them). Sometimes the contrast 
is difficult to read. I don't have vision issues and I have struggled." 

Lack of access to 
tools 

2 "Web applications are difficult to test without a good screen reader", 
"Lack of a tool for automated ongoing review, identification and 
resolution of issues" 

Accessibility not 
part of (primary) 
duties 

2 "not a part of duties at the moment", "It's just one of my many hats, 
not my primary task and I don't feel I have the time required be 
excellent at it.  " 
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Barrier Count Comments 

Things not 
working 
properly 

1 "My webpage doesn't show up in Google searches even though it has 
meta tags." 

Lack of training 1 "I wasn't trained in this area, so I lack current knowledge" 

Hard to 
remember 
about it 

1 "forgetfulness as it doesn't come to mind when I make web-pages & 
tutorials" 

Other 1 "other staff follow-up" 

Lack of 
established 
workflow 

1 "It does not seem like there is any schedule for review of content to 
ensure accessibility, and I have not found it to be part of the process 
flow for adding or editing content either." 

 
Appendix D: Focus Group Suggestions 
 

Group 
votes 

Suggestion Author's 
top 3 

Comments 

5 Peer or expert review 
process 

Y Dan: OCCS does code reviews; this could be 
similar. Perhaps we could find someone in 
OCCS to teach us how to conduct. A process for 
every job, though, would be a difficult 
challenge. 

4 Statement about 
accessibility (high level; 
positive) 

Y Dan: PSD management tepid in the past; go 
through Kathel's IDEA group? 

3 Change NLM culture so 
that accessibility is a 
priority 

Y Dan: I like the concept of "Free the willing," 
meaning, find the people whose beliefs and 
actions are the change that the organization 
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

needs; then help them and highlight their work. 
People don't like it when you try to change 
them, but will change if they see it's 
advantageous to them. This is a paraphrase 
from Peter Senge; also, from Systems Thinking 
and the Gap between Aspirations and 
Performance, 

• If you can connect places where people 
are operating in the new-cultural way, 
with an ability to solve problems that 
are really bugging people, you will have 
something that you can grow and 
shape. Instead of centering the change 
process around ‘culture change,’ center 
it around something that is useful and 
happening now, that people care 
about. Instead of getting resistance you 
will get something you can accelerate, 
shape, and influence. 

• And go to that place and say, “Hey, 
that’s pretty cool! Do you want to do 
more? What more would you want to 
do?” Honor the people who are 
committed. Go where the energy is 
already moving and help them. 

3 Appoint person for each 
kind of thing, e.g. video, 
social media 

Y Dan: Not bad per se, for providing help; but 
could be interpreted as the SuperHero model, 
find someone to do the work. 

2 IDEA council: Focus on 
what staff needs are 

Y Dan: Referral to Kathel's IDEA group 

2 NLM 508 working group 
/ Community of Practice 

Y Dan: New MS Teams area that is a discussion 
forum similar to the Visualization CoP? 

https://www.garrisoninstitute.org/video/systems-thinking-and-the-gap-between-aspirations-and-performance/
https://www.garrisoninstitute.org/video/systems-thinking-and-the-gap-between-aspirations-and-performance/
https://www.garrisoninstitute.org/video/systems-thinking-and-the-gap-between-aspirations-and-performance/
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

2 Someone authorized to 
sign off on products 

Y 
 

1 Have small team or 
designated contact we 
can go to with questions 

Y 
 

1 Make accessibility a part 
of more discussions 

Y 
 

1 Implement more page 
templates; e.g., for job 
listings) that are already 
accessible (i.e., using 
forms to fill in content) 

Y Dan: Ying Sun of the OCCS Web Team set a goal 
to have "the first round" of pages converted to 
USWDS by the end of calendar year 2022. How 
can we help her team?  

1 Define page owners 
across the website, so 
it’s easy to find the right 
point of contact 

Y Dan: I have this inventory with names, except 
for NCBI. Can my product inventory file become 
a staff-facing browser-and-SQL-based resource 
similar to GSA's Enterprise Digital 
eXperience inventory? Could be used by OCPL, 
OCCS Web Team, OCCS Analytics Team, for 
work, content promotion, content syndication 
storefront, accessibility compliance... 

1 More consistent 
guidance for captioning 
and Audio Description 
scripting 

Y Dan: NLM has OCPL staff proficient in video; it 
seems NLM is held back in leveraging this on 
social media, etc. 

1 Letting people know they 
have help with 
accessibility issues in 
whom to contact 

Y 
 

https://wiki.nlm.nih.gov/confluence/display/WEBDS/Inventory+of+public-facing+web+products
https://github.com/GSA/EDX/blob/main/Data/touchpoints-data-dictionary-2021-11.csv
https://github.com/GSA/EDX/blob/main/Data/touchpoints-data-dictionary-2021-11.csv
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

1 Better and more positive 
promotion of 
accessibility 

Y 
 

1 “Gold standard“ 
examples 

Y 
 

0 An accessibility "trainer" 
who can provide training 
to staff 

Y 
 

0 Help with decision-
making when issues 
become complex 

Y 
 

0 Have as many "good" 
and "bad" examples as 
possible 

Y 
 

0 Just in time tutorial 
(simple text fine) for 
each type of resource 

Y 
 

0 Call-A-Buddy program Y 
 

0 More training / 
information sessions to 
create more visibility 

Y 
 

0 Have all staff make it a 
priority; e.g., have 
supervisors mention it 

Y 
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

0 Good software that 
holds my hand through 
the process 

Y 
 

0 Build culture: awareness 
and celebratory events 

Y 
 

0 Centralized support 
team/services 

Y 
 

0 Checklists that are 
comprehensive and 
authoritative 

Y 
 

0 Single point of contact 
for questions 

Y 
 

0 Experts on certain 
products, instead of each 
person being an expert 
on each 

Y 
 

0 Ask staff members 
submitting images for 
the website, social 
media, etc. to include alt 
text 

Y 
 

0 is there NLM 
organization home? 

Y 
 

0 Create wiki page guide N 
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

0 Create recording with 
how to instructions 

N 
 

0 Develop an ideal site 
map for the website that 
defines its structure 

N 
 

0 Do an analysis of all 
images on the website to 
make sure they have 
proper all text 

N 
 

0 Ensure consistency and 
title sizes, fonts, etc. 

N 
 

0 Ensure all URLs are 
logical to boost SCO and 
help users find what 
they’re looking for 

N 
 

0 Encourage staff 
members to define what 
exactly they mean when 
referring to 508 
compliance 

N 
 

0 Ensure bread crumbs on 
the website accurately 
portray where you are in 
the structure 

N 
 

0 Using motivation for 
thinking about 

N 
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

accessibility early and 
development of projects 

0 NLM @Work wiki N 
 

0 NLM’s statement on 
commitment to 
accessibility 

N 
 

0 Start with guidance by 
format 

N 
 

0 Assign responsibility by 
format 

N 
 

0 Basic tools Dash 
worksheets for staff to 
follow to create 
accessible content 

N 
 

0 Embed guidance in 
NLM’s templates “like 
PPT“ 

N 
 

0 Make clear and advertise 
“gate keepers quote for 
508 

N 
 

0 Accessibility office hours N 
 

0 Intro "Just the basics" 
training for contractors 

N 
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

0 Prepackaged lessons for 
staff meetings 

N 
 

0 Centralized office with 
review services 

N 
 

0 Increase feasibility of 
accessibility topics and 
resources; e.g., advertise 
more 

N 
 

0 Simple checklists for new 
people in very plain 
language 

N 
 

0 Easy to use software 
would be great, but topic 
is very new to me, so 
people or more training 
would help to reprogram 
me so that it is a priority 

N 
 

0 Well known SMEs on 
accessibility 

N 
 

0 Access to people who do 
a task all the time 

N 
 

0 Videos that show you 
how to use the 
software‘s built-in 
accessibility features 

N 
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Group 
votes 

Suggestion Author's 
top 3 

Comments 

0 People advocating across 
NIH for support 

N 
 

0 Centralized wiki for NLM-
WIM that keeps us on 
the same page 

N 
 

0 Contract specialists 
familiar with 508 
requirements 

N 
 

0 Communities of practice 
groups for particular 
software 

N 
 

0 Standard staff access to 
software 

N 
 

0 Point person for 
compliance on each unit 

N 
 

0 Ways to report clearly 
non-accessible 
pages/products 

N 
 

0 PMAP language N 
 

0 Resources for all NLM 
(not just LO for example) 

N 
 

0 Plain language 
expectations 

N 
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Appendix E: Interactive PDF Accessibility Checklist (Prototype) 
 

Does your PDF include: 

� Color 
� Links 
� Images 
� Tables 
� Forms 
� Time-based media (audio, video) or animated content 

Best Practices 
1. The Document Properties > Description “Application” or “PDF Producer” displays “Adobe 

LiveCycle Designer” 
a. Solution: If it does, please contact your Section 508 program team for guidance. 
b. Tags: all 

2. The Document Properties > Security > “Content Copying for Accessibility” displays “Allowed” 
a. Solution: If it doesn’t, update the security settings to display “allow” for “content 

copying for accessibility.” 
b. Tags: all 

3. The Accessibility Full Check (Tools > Accessibility > Full Check/ Accessibility Check) does NOT 
display “Scripts – Needs manual check” under the “Page Content”  

a. Solution: If it does, use web and applications checklist in addition to the PDF checklist. 
b. Tags: all 

4. If no method exists to correct content to meet Section 508 accessibility requirements, an 
alternate version is provided. 

a. Solution: If no method exists to correct content and an alternate accessible version is 
not provided, contact your Section 508 program team for alternate content options. 

b. Tags: all 
5. If document links to or embeds another file, these files also been reviewed using this checklist. 

a. Solution: Review linked or embedded files using this checklist. 
b. Tags: all 

Layout and Formatting 
1. “Yes” is displayed next to “Tagged PDF” under Document Properties > Description > Advanced. 

a. Notes: Tags allow screen reader and other assistive technology users to interact with 
and navigate through the PDF. Without tagging a PDF may be difficult or impossible to 
use for many assistive technology users. 

b. Solution: If the PDF was created from a Microsoft Office Word or PowerPoint document, 
it is easier to create the tags in the original document and save it as an accessible PDF. 
Microsoft-Create accessible Office documents. If that is not an option, tag the PDF in 
Adobe Acrobat by going to Tools >  Accessibility > Add Tags to Document. This will 
automatically tag the PDF but manual touchup may be required, especially if there are 
complex layouts or page elements. Adobe-Creating Accessible PDFs 

https://support.microsoft.com/en-us/office/create-accessible-office-documents-868ecfcd-4f00-4224-b881-a65537a7c155
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/helpx.adobe.com/acrobat/using/creating-accessible-pdfs.html
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c. Standards: WCAG 1.3.1, WCAG 4.1.1 
d. Tags: all 

2. Tags are used to structure content in a valid manner. 
a. Notes: Tags may be present but inaccurate or insufficient. For example, decorative 

elements may incorrectly be tagged as figures or elements may be missing tags. Read 
through the tags and verify that each element is labeled with the correct tag by using 
the Full Check/ Accessibility Check tool (Tools > Accessibility > Full Check/ Accessibility 
Check) or the Reading Order tool (Advanced > Accessibility > TouchUp Reading Order > 
Show Order Panel). Adobe-Creating Accessible PDFs 

b. Solution: If tags are applied incorrectly, edit the tags as necessary using the Tag Panel > 
Tag Tree. 

c. Standards: WCAG 1.3.1, WCAG 4.1.2 
d. Tags: all 

3. Non-standard tags (if present) are mapped appropriately in the Role Map. 
a. Notes: Non-standard tags should be used only if none of the standard tags apply.  
b. Solution: If non-standard tags are necessary, they should be mapped to the most similar 

standard tag using Tags pane > Options > Edit Role Map > New Item > Add Role. Tagged 
PDF Non-Standard Structure Type 

c. Standards: WCAG 1.3.1, WCAG 4.1.2 
d. Tags: all 

4. Tags are used appropriately to designate headings. 
a. Notes: Headings should be tagged as headings (<H1>, <H2>, etc) rather than as 

paragraphs (<P>) or other elements. This can be checked using the Touchup Reading 
Order tool (Advanced > Accessibility > TouchUp Reading Order > Show Order Panel). 
WCAG-Providing Headings 

b. Solution: Edit the tags as necessary using the Touchup Reading Order tool. 
c. Standards: WCAG 1.3.1 
d. Tags: all 

5. Heading tags are provided in the appropriate sequence (<H1>, <H2>, <H3>, etc). 
a. Notes: Headings should be tagged in the correct order – the highest order heading 

(usually at the beginning of the document should be H1, the next level subheadings 
should be H2, followed by H3, etc. without skipping levels). This can be checked using 
the Touchup Reading Order tool (Advanced > Accessibility > TouchUp Reading Order > 
Show Order Panel). WCAG-Providing Headings 

b. Solution: Edit the tags as necessary using the Touchup Reading Order tool. 
c. Standards: WCAG 1.3.1 
d. Tags: all 

6. If Table of Contents lists are present, tags used appropriately to structure them (<TOC>, 
<TOCI>). 

a. Notes: The entire table of contents should be tagged as <TOC>, each individual entry 
should be tagged as <TOCI>. Lists of figures, tables, and bibliographies can also be 
tagged using <TOC> and <TOCI>. This can be checked using View > Navigation Panels > 
Tags. Level Access-PDF Table of Contents 

b. Solution: Change the tags as necessary using the Tags panel. 

https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#parsing
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/helpx.adobe.com/acrobat/using/creating-accessible-pdfs.html
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231%2C411#name-role-value
https://taggedpdf.com/508-pdf-help-center/non-standard-structure-type-is-not-mapped/
https://taggedpdf.com/508-pdf-help-center/non-standard-structure-type-is-not-mapped/
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231%2C411#name-role-value
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF9.html
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF9.html
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.levelaccess.com/pdf-table-of-contents/
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c. Standards: WCAG 1.3.1 
d. Tags: all 

7. If lists are present, tags are used appropriately to structure sub-lists (at minimum, <L> and <LI>). 
a. Notes: The entire list should be tagged as <L> and each individual list item should be 

tagged as <LI>. <LBody> can also be used for nested lists. This can be checked using 
View > Navigation Panels > Tags. WCAG-Using List tags  

b. Solution: Change the tags as necessary using the Tags panel. 
c. Additional resources: Level Access-PDF Table of Contents 
d. Standards: WCAG 1.3.1 
e. Tags: all 

8. Tables are NOT used to construct layout. 
a. Notes: Table tags should be used only to present tabular data not for layout purposes. 

Information that is organized sequentially or is self-explanatory, rather than 
categorized, should not be tagged as a table. Check if table tags are used for layout by 
using View > Navigation Panels > Tags. Level Access-The Trouble with Tables 

b. Solution: If the table is used for layout purposes not for presenting data, all the table’s 
tags should be removed from the Tags structure using the Tags panel. Make sure that all 
content is still tagged appropriately (ex. headings, paragraphs, figures, lists). 

c. Standards: WCAG 1.3.1 
d. Tags: all 

9. The reading and navigation order is logical and intuitive. 
a. Notes: The reading/navigation order is the order in which screen readers and other 

assistive technologies will present content to the user. This order should generally 
match the visual order. For complex layouts (ex. side panels), the reading/ navigation 
order should make sense but does not have to be left-right, top-bottom. Order can be 
checked by going to View > Navigation Panes > Tags or the Touchup Reading Order tool 
(Advanced > Accessibility > TouchUp Reading Order > Show Order Panel). WCAG-
Ensuring Correct Tab and Reading Order 

b. Solution: If the reading/navigation order doesn’t follow the visual order and doesn’t 
make sense, the elements should be reordered using the Tags panel or the Touchup 
Reading Order tool. 

c. Standards: WCAG 1.3.2 
d. Tags: all 

10. All meaningful content appears in the Tags pane. 
a. Notes: All meaningful content (anything that isn’t a purely decorative element) should 

have a tag. If content is not tagged, screen reader and other assistive technology users 
may not be able to read or interact with that content. Tags can be checked by going to 
View > Navigation Panes > Tags. 

b. Solution: If any meaningful content is missing a tag, add the appropriate tag in the Tags 
panel (Tag Panel > Tag Tree). 

c. Standards: WCAG 1.3.2 
d. Tags: all 

11. Vital content from a header, footer, or watermark is provided in the document. 

https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF21.html
https://www.levelaccess.com/pdf-table-of-contents/
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/levelaccess.com/trouble-tables-brief-introduction/
https://nih-my.sharepoint.com/personal/kudryashovld_nih_gov/Documents/w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#info-and-relationships
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF3.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF3.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231%2C131#meaningful-sequence
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231%2C131#meaningful-sequence
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a. Notes: There is conflicting guidance on this issue from WCAG and PDF/UA. Generally, 
the first occurrence of identical headers, footers, or vital watermarks should be tagged 
as text (ex. paragraph), whereas additional occurrences should be marked as artifacts so 
they do not interfere with screen reader use of the document. In cases of unique 
headers and footers such as section or page numbers that don’t match the document 
page numbers, this may be vital information that should be tagged as text to be made 
accessible to screen readers. Level Access-PDF Accessibility Q&A 

b. Solution: If headers, footers, or watermarks provide vital content, they should be tagged 
appropriately by going to View > Navigation Panes > Tags. Alternatively, the vital 
content could be repeated in the body of the document, and the header, footer, or 
watermark can be marked as an artifact. 

c. Standards: WCAG 1.3.3 
d. Tags: all 

12. Content that is repetitive or decorative is changed to an artifact. 
a. Notes: Screen readers ignore content that is marked as an artifact, so this should be 

done to any content that is not meaningful (ex. decorative borders) or is repeated more 
than once (ex. identical headers). This can be checked by going to View > Navigation 
Panes > Tags. Anything marked as an artifact will not appear in the Tags panel. 

a. Solution: If the decorative or repetitive content is not tagged as an artifact, go to Tag 
Panel > Tag Tree and edit the corresponding tag. Adobe-Tagging Content as an Artifact 

b. Standards: WCAG 1.3.4 
b. Tags: all 

13. Instructions do NOT rely on shape, size, or visual location (ex. “Click the square icon to 
continue”, “Instructions are in the right-hand column”). 

a. Notes: Instructions based on visual characteristics alone make it difficult or impossible 
for people with visual disabilities to use the document. These instructions could also be 
implicit (ex. assuming that users will understand that a green arrow symbol means 
“continue”). 

b. Solution: Rewrite instructions to rely on non-sensory elements in addition to the 
sensory characteristics (ex. label the button or field with text). WCAG-Providing Textual 
Identification 

c. Standards: WCAG 1.3.3 
d. Tags: all 

14. Instructions do NOT rely on sound (ex. “A beeping sound indicates you may continue”). 
a. Notes: Instructions based on sound make it difficult for deaf and hard of hearing people 

to use the document. This is unlikely to happen in a PDF document since sound is rarely 
used. 

b. Solution: Rewrite instructions to rely on non-sensory elements in addition to the 
sensory characteristics (ex. provide the amount of time users should wait until 
proceeding). WCAG-Providing Textual Identification 

c. Standards: WCAG 1.3.3 
d. Tags: all 

15. Text and images of text have a contrast ratio of at least 4.5:1. 

https://www.levelaccess.com/more-q-a-from-the-pdf-accessibility-webinar/
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C142%2C222%2C231%2C133#sensory-characteristics
https://blog.adobe.com/en/publish/2017/07/25/accessible-pdfs-in-acrobat-dc-tagging-content-as-an-artifact
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C142%2C222%2C231%2C134#orientation
https://www.w3.org/WAI/WCAG21/Techniques/general/G96.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G96.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C142%2C222%2C231%2C133#sensory-characteristics
https://www.w3.org/WAI/WCAG21/Techniques/general/G96.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C142%2C222%2C231%2C133#sensory-characteristics
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a. Notes: High levels of contrast ensure that people with low vision and color blindness can 
read and use the document. Color contrast can be checked using the Full Check/ 
Accessibility Check tool (Tools > Accessibility > Full Check/ Accessibility Check). However, 
images of text will not be checked using this tool and will require a manual review (ex. 
using a color picker tool in a program like Photoshop or PowerPoint in combination with 
WebAIM-Contrast Checker). 

b. Solution: Edit the foreground and/or background colors to reach a contrast of at least 
4.5:1. WebAIM-Contrast Checker can be used to find an acceptable color combination 
(use WCAG AA guidelines for normal or large text as applicable). 

c. Standards: WCAG 1.4.3 
d. Additional resources: WebAIM-Contrast and Color Accessibility 
e. Tags: all 

16. The document is readable and functional when the text is set to reflow. 
a. Notes: Test by going to View > Zoom > Reflow. The document should display in a single 

column taking up the full width of the page. Make sure all meaningful elements are still 
present in reflow, the order makes sense, and functionality is preserved. Reflow allows 
people with low vision to zoom in and more effectively read the document. 

b. Solution: Correct issues as necessary. If an element is missing, make sure it has the 
proper tag using Tag Panel > Tag Tree (note that anything marked as an artifact will not 
appear in reflow). If elements are out of order, change the reading order using the 
TouchUp Reading Order tool (Advanced > Accessibility > TouchUp Reading Order > Show 
Order Panel). 

c. Standards: WCAG 1.4.4 
d. Additional resources: Adobe-Reading PDFs with reflow 
e. Tags: all 

17. The “Scanned Page Alert” does NOT appear when the document is opened. The Tools > 
Accessibility > Full Check > Document category does NOT say “Failed” for “Image-only PDF” or 
“Tagged PDF”. 

a. Notes: If the PDF fails any of these checks, it will be very difficult or impossible to use for 
blind users and users with other disabilities.  

b. Solution: If this PDF was created using a different program such as Microsoft Office 
Word or PowerPoint, it is more efficient to return to the original file, run the Microsoft 
Accessibility Checker, fix any errors, and save the file as an accessible PDF. Microsoft-
Improve accessibility with the Accessibility Checker | Microsoft-Create accessible PDFs. 
If this is not possible, these issues can also be fixed in Adobe Acrobat Pro. To fix an 
image only PDF, use Optical Character Recognition (OCR) to convert the image into text 
by going to Document > OCR Text Recognition > Recognize Text Using OCR. Select “All 
Pages”, click “OK”, select “Edit” under Settings, and select “Formatted Text and 
Graphics” in the PDF Output Style. Check and fix any suspect OCR by going to Document 
> OCR Text Recognition > Find First OCR Suspect. To fix an untagged PDF, go to 
Advanced > Accessibility > Add Tags to Document. Check that the tags are correct by 
going to Tag Panel > Tag Tree. WCAG-Performing OCR on a scanned PDF 

c. Standards: WCAG 1.4.5 
d. Tags: all 

https://webaim.org/resources/contrastchecker/
https://webaim.org/resources/contrastchecker/
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C142%2C222%2C231%2C134#contrast-minimum
https://webaim.org/articles/contrast/
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C142%2C222%2C231%2C134#resize-text
https://helpx.adobe.com/acrobat/using/reading-pdfs-reflow-accessibility-features.html
https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f
https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f
https://support.microsoft.com/en-us/office/create-accessible-pdfs-064625e0-56ea-4e16-ad71-3aa33bb4b7ed#:%7E:text=Office%20for%20web-,Before%20generating%20your%20PDF%2C%20run%20the%20Accessibility%20Checker%20to%20make,for%20the%20web%20dialog%20box.
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF7.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231#images-of-text
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18. The document has a meaningful title indicating its purpose under Document Properties > 
Description > “Title” AND Document Properties > Initial View > Window Options > Show is set to 
“Document Title”. 

a. Notes: Meaningful titles allow screen reader users to quickly and easily navigate 
between documents without having to read the document itself. Examples of 
meaningful titles include “Tax Form 1040” or the title of the article contained in the 
document. Examples of titles that are not meaningful include random strings of 
characters or generic titles such as “document 1”. The document title is not the same 
thing as the file name. 

b. Solution: Change the title to be more meaningful in Document Properties and set 
“Show” to “Document Title”. 

c. Standards: WCAG 2.4.2 
d. Additional resources: WCAG-Specifying the document title 
e. Tags: all 

19. Page headings and labels for form and interactive controls are informative. 
a. Notes: Headings and labels should not be duplicated (ex. “More Details”, “First Name”) 

unless the structure provides adequate differentiation between them. 
b. Solution: Change uninformative or duplicate headings and labels to be more informative 

and unique (ex. change multiple “More Details” headings to “Biology”, “Chemistry”; 
change multiple “First Name” fields to “Customer First Name”, “Spouse First Name”). 

c. Standards: WCAG 2.4.6 
d. Tags: all 

20. The document displays the appropriate language under Document Properties > Advanced > 
Reading Options > Language. 

a. Notes: The language property allows screen readers to read the text in the correct 
language. Without this property, a screen reader may use the wrong set of speech rules 
resulting in incomprehensible content. 

b. Solution: Select the appropriate language in the field if missing or incorrect. 
c. Standards: WCAG 3.1.1 
d. Additional Resources: WCAG-Setting the default language 
e. Tags: all 

21. If some of the page content is in a language different from the main language of the page, this 
content is identified through the Properties of the affected tag(s) under the Tag tab > Language. 

a. Notes: This allows screen readers to correctly switch between languages when reading 
content written in different languages. 

b. Solution: Update the Language properties for the appropriate tags as necessary. 
c. Standards: WCAG 3.1.2 
d. Additional resources: WCAG-Specifying the language for a passage or phrase 
e. Tags: all 

Functionality 
1. All functionality is available using the keyboard.  

a. Notes: Test if you can do everything you can with a mouse (ex. focus on elements, 
activate elements, follow links, fill out forms) using only a keyboard. Use standard 
keyboard controls (Tab, Shift + Tab, and/or arrow keys to move between elements; 

https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242#page-titled
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF18.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242#headings-and-labels
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242%2C246#language-of-page
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF16.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242%2C246%2C311#language-of-parts
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF19.html
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Spacebar or Enter to activate elements) to test. Make sure you can type in all open-text 
form fields. Functionality that cannot be accomplished by a keyboard (ex. free hand 
drawing) is exempt from this requirement. 

b. Solution: If form controls are not keyboard accessible, use Advanced > Accessibility > 
Run Form Field Recognition to automatically detect form fields and edit them as 
necessary using “Properties” in the context menu for each field. WCAG-Providing 
interactive form controls. If links are not keyboard accessible, edit them by selecting the 
text, accessing the context menu, and selecting “Create Link.” WCAG-Providing links. 

c. Standards: WCAG 2.1.1 
d. Tags: all 

2. The navigation order of links, form elements, etc. is logical and intuitive. 
a. Notes: When you tab through the PDF, does the order in which elements are reached 

make sense or does it jump around in a way that may be confusing? 
b. Solution: Edit the order of focusable elements in the Tag panel (Tag Panel > Tag Tree) to 

be more logical and intuitive. WCAG-Ensuring correct tab and reading order 
c. Standards: WCAG 2.1.1; WCAG 2.4.3 
d. Tags: all 

The items below are usually not applicable to PDFs 

3. All functionality is operable without requiring specific timings for individual keystrokes. 
a. Notes: This is generally true for PDFs unless the PDF is using advanced scripts requiring 

custom keystrokes. 
b. Solution: Use standard keyboard controls for all functionality. 
c. Standards: WCAG 2.1.1 
d. Tags: all 

4. You can navigate to and from all navigable page elements (ex. embedded objects, links, form 
fields) using only a keyboard without getting locked or trapped at one particular page element. 

a. Notes: This requirement is not fulfilled if keyboard navigation gets stuck at an element 
and mouse use is required to move away to other elements in the document. This is also 
generally true for PDFs. 

b. Solution: Remove or edit the controls for the element creating the keyboard trap. 
c. Standards: WCAG 2.1.2 
d. Tags: all 

5. Keyboard focus moves to and returns from elements appropriately (ex. the opening or 
appearance and closing of dialogs). 

a. Notes: This should be true if standard PDF elements are used. 
b. Solution: Edit the control by going to “Properties” in the context menu for the field. 

WCAG-Providing interactive form controls 
c. Standards: WCAG 2.4.3 
d. Tags: all 

6. It is visually apparent which element has the current keyboard focus (i.e., as you tab through the 
page, you can see where you are). 

a. Notes: This should generally be true for PDFs if the correct elements and tags are used. 
b. Solution: Ensure that the form element or link are correctly specified.  

https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF23.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF23.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF11.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242%2C246%2C311%2C312#keyboard
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF3.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242%2C246%2C311%2C312#keyboard
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C246%2C311%2C312%2C243#focus-order
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C222%2C231%2C242%2C246%2C311%2C312#keyboard
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C222%2C231%2C242%2C246%2C311%2C312#no-keyboard-trap
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF23.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C246%2C311%2C312%2C243#focus-order
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c. Standards: WCAG 2.4.7 
d. Tags: all 

7. When a page element receives focus, it does NOT result in a substantial change to the page, the 
spawning of a pop-up window, an additional change of keyboard focus, or any other change that 
could disorient the user. 

a. Notes: This is generally true for PDFs unless custom scripts are used. 
b. Solution: Update the action to occur on element activation (mouse click or keyboard 

activation) rather than on focus, or remove the custom script altogether. 
c. Standards: WCAG 3.2.1 
d. Tags: all 

8. If there is a time limit, the user is given options to turn off, adjust, or extend that time limit. 
a. Notes: Real-time events (ex. an auction), situations in which the time limit is absolutely 

required, and time limits greater than 20 hours are exempt from this requirement. This 
is usually not an issue for PDFs. 

b. Solution: Remove the time limit unless it is absolutely required or the limit is greater 
than 20 hours. 

c. Standards: WCAG 2.2.1 
d. Tags: all 

Color 
1. Color is NOT used as the sole method of conveying content or distinguishing visual elements. 

a. Notes: If color is used as the only way to convey information, many color blind and 
visually disabled users may not be able to access that information. Color can be used but 
should be accompanied by other means of conveying the information, for example text 
labels (each section of a pie chart being labeled with the corresponding text rather than 
a separate legend that requires color differentiation to interpret), shapes (green check 
box and red x, rather than only green and red colors; links being underlined in addition 
to a change in color), and patterns (values being represented by different patterns as 
well as colors on a bar chart). When possible, text labels should be used as they are 
more broadly accessible (color blind users will be able to differentiate between shapes 
or patterns but blind screen reader users will not, unless text alternatives are provided). 

b. Solution: Add other non-color based means of conveying the information. 
c. Standards: WCAG 1.4.1 
d. Additional resources: WCAG-Ensuring that information conveyed by color differences is 

also available in text | WCAG-Ensuring that additional visual cues are available | WCAG-
Using color and pattern 

e. Tags: color 

Links 
1. All links are properly structured using the <Link> tag with a nested <Link-OBJR> tag? 

a. Notes: Check using the tag tree (Tag Panel > Tag Tree). Proper tagging allows screen 
reader users to interact with and follow the link. 

b. Solution: If the PDF was created from a Microsoft Office Word file and you have access 
to the original Word file, make sure the link is created using the built-in Word “Link” tool 
and save the file as a tagged PDF. Microsoft-Create accessible PDFs. If this is not an 

https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C246%2C311%2C312%2C243#focus-visible
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#on-focus
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#timing-adjustable
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333#use-of-color
https://www.w3.org/WAI/WCAG21/Techniques/general/G14.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G14.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G182.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G111.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G111.html
https://support.microsoft.com/en-us/office/create-accessible-pdfs-064625e0-56ea-4e16-ad71-3aa33bb4b7ed#:%7E:text=Office%20for%20web-,Before%20generating%20your%20PDF%2C%20run%20the%20Accessibility%20Checker%20to%20make,for%20the%20web%20dialog%20box.
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option, create the link in Adobe Acrobat Pro by selecting the text, accessing the context 
menu, and selecting “Create Link”. WCAG-Providing links 

c. Standards: WCAG 1.3.1; WCAG 2.1.1; WCAG 4.1.2 
d. Tags: links 

2. The purpose of each link (or form image button) can be determined from the link text alone, or 
from the link and its content (ex. surrounding paragraph, list item, table cell, or table headers). 

a. Notes: Screen reader users can access a list of all links in a document, so providing 
descriptive links helps screen reader users find relevant links more efficiently. 
Otherwise, users may get a list of twenty “click here” links and have to spend a long 
time finding the right one. 

b. Solution: Update the link text to convey the purpose of the link (ex. change “click here” 
to “search PubMed”). If it is necessary to provide description beyond what can be 
included in the text label of the link, an /Alt entry can be used (View > Navigation Panels 
> Tags > Link tag > context menu > Properties > TouchUp Properties > Tags tab > 
Alternate Text). WCAG-Providing replacement text using the /Alt entry 

c. Standards: WCAG 2.4.4 
d. Additional resources: WCAG-Providing link text that describes the purpose 
e. Tags: links 

3. Links (or form image buttons) with the same text that go to different locations are readily 
distinguishable. 

a. Notes: Since screen reader users can access a list of all the links in the document, users 
will generally assume that links labeled with the same text will lead to the same 
location. 

b. Solution: Change the text of the link to clearly describe the different locations (ex. “Find 
on PubMed”, “Find on Google Scholar”). Alternatively, if it is necessary to keep the link 
text the same, the /Alt entry can be used, which will replace the link text with the 
specified alternative text for screen reader users (View > Navigation Panels > Tags > Link 
tag > context menu > Properties > TouchUp Properties > Tags tab > Alternate Text). 
WCAG-Providing replacement text using the /Alt entry 

c. Standards: WCAG 2.4.4 
d. Tags: links 

4. Color is NOT used as the sole method to distinguish links from surrounding text OR the contrast 
between the link and the surrounding text is at least 3:1 and an additional differentiation is 
provided (ex. an underline appears) when the link is hovered over or receives keyboard focus. 

a. Notes: In a PDF, it is easiest to make sure that the links are appropriately tagged and 
default (or more accessible) styling for links is maintained, as the default styling will 
include an underline. 

b. Solution: Make sure the links are properly tagged by selecting the text, accessing the 
context menu, and selecting “Create Link”. WCAG-Providing links. If they are and still are 
not underlined or otherwise indicated, change the appearance of the link to include an 
underline or other visual non-color indicator by going to Tools > Edit PDF > Link > Add or 
Edit, double-clicking the link rectangle, and going to the “Appearance” tab in the “Link 
Properties” dialog box. Adobe-Create a link 

c. Standards: WCAG 1.4.1 

https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF11.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333#info-and-relationships
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333#keyboard
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C141%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333%2C412#name-role-value
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF13.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C141%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333%2C412#link-purpose-in-context
https://www.w3.org/WAI/WCAG21/Techniques/general/G91.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF13.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C141%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333%2C412#link-purpose-in-context
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF11.html
https://helpx.adobe.com/acrobat/using/links-attachments-pdfs.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C141%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333%2C412%2C244#use-of-color
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d. Tags: color 

Images 
2. All images and form image buttons have appropriate, concise alternative text. 

a. Notes: Full check (Tools > Accessibility > Full Check/ Accessibility Check) will catch empty 
alternative text but check that the alternative text provided is meaningful. Alternative 
text should be 1-2 sentences providing sufficient detail for someone who cannot see the 
image to understand its purpose. You can check alt text using: Order Panel icon in left 
nav bar > Page through document; alt text should be super-imposed on images. You 
could also use the Touchup Reading Order tool (Advanced > Accessibility > TouchUp 
Reading Order > Show Order Panel). 

b. Solution: If there are any missing or inadequate alternative texts, add or edit a short 
description by going to Tools > Advanced Editing > TouchUp Object Tool > TouchUp 
Properties > Tag > Alternative Text. WCAG-Adding alt text 

c. Additional Resources: HHS-Testing for alt text | HHS-Editing PDF Image Tags | WebAIM-
Adding alt text | WebAIM-Artifacts |  W3C-Images Tutorial 

d. Standards: WCAG 1.1.1 
e. Tags: images 

3. All images that do not convey content, are decorative, or with content that is already conveyed 
in text are changed to artifacts. 

a. Notes: This can be checked using the Touch Up Reading Order tool (Advanced > 
Accessibility > TouchUp Reading Order > Show Order Panel). Images that have been 
tagged as artifacts will not show a tag. 

b. Solution: If the image is not tagged as an artifact, go to Tag Panel > Tag Tree and edit the 
corresponding tag. Adobe-Tagging Content as an Artifact 

c. Additional Resources: WCAG-Hiding decorative images | W3C-An Alt Decision Tree 
d. Standards: WCAG 1.1.1 
e. Tags: images 

4. Equivalent alternatives to complex images provided in context or on a separate (linked and/or 
referenced) page. 

a. Notes: This is necessary only if the meaning of the image cannot be adequately 
conveyed in 1-2 sentences. 

b. Solution: If there are any complex images that require more than 1-2 sentences to 
adequately describe (and the description is not already present in a caption or 
document text), a long description should be added either in a caption or surrounding 
text or by adding a link to another page or document with the description. WCAG-Long 
description in link | WCAG-Long description with reference | WCAG21-Long description 
in text 

c. Standards: WCAG 1.1.1 
d. Tags: images 

5. Images of text or that include text (ex. logos) have that text as part of the alternative text 
description. 

a. Notes: Check the same way as checking presence and quality of alt text. 
b. Solution: if any images of text don’t include that text in the description, update the 

alternative text to include the text in the image by going to Tools > Advanced Editing > 

https://www.w3.org/TR/WCAG20-TECHS/pdf.html#PDF1
http://www.hhs.gov/web/508/testdocuments.html#mod3sec2
http://www.hhs.gov/web/508/editpdfimagetag.html
http://webaim.org/techniques/acrobat/acrobat#alt_text
http://webaim.org/techniques/acrobat/acrobat#alt_text
http://webaim.org/techniques/acrobat/acrobat#artifacts
https://www.w3.org/WAI/tutorials/images/
https://www.w3.org/TR/WCAG21/#non-text-content
https://blog.adobe.com/en/publish/2017/07/25/accessible-pdfs-in-acrobat-dc-tagging-content-as-an-artifact
http://www.w3.org/TR/WCAG20-TECHS/pdf.html#PDF4
https://www.w3.org/WAI/tutorials/images/decision-tree/
https://www.w3.org/TR/WCAG21/#non-text-content
https://www.w3.org/WAI/WCAG21/Techniques/general/G73.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G73.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G74.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G92.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G92.html
https://www.w3.org/TR/WCAG21/#non-text-content
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TouchUp Object Tool > TouchUp Properties > Tag > Alternative Text. WCAG-Adding alt 
text 

c. Standards: WCAG 1.1.1 
d. Tags: images 

6. Non-text content (ex. images) that use color also use patterns to convey the same information. 
a. Notes: This primarily applies to data visualizations that use colors to differentiate 

between elements. 
b. Solution: Update the images to include patterns in addition to colors. WCAG-Using color 

and pattern 
c. Standards: WCAG 1.4.1 
d. Tags: images 

Tables 
1. Table tags are used for tabular data. 

a. Notes: Table tags allow screen reader users to understand and navigate through tabular 
data. Make sure that everything that looks like a table and has tabular data is properly 
tagged as a table. Check using View > Navigation Panel > Tags.  

b. Solution: If the document was created using Microsoft Office Word or PowerPoint, use 
the built-in Microsoft tables tool for the table. Otherwise, add <Table>, <TR>, <TH>, and 
<TD> tags in Adobe Acrobat Pro by going to View > Navigation Panel > Tags. WCAG-
Using table elements. You can also use the Table Editor. 

c. Standards: WCAG 1.3.1 
d. Tags: tables 

2. Data table headers are appropriately identified (ex. <TH> for simple tables, header attribute for 
complex tables). 

a. Notes: Headers must be not only marked visually but also tagged as <TH> for screen 
reader users to be able to understand the content and relationships described in the 
table. Check using View > Navigation Panel > Tags. 

b. Solution: Change the <TD> tags for each of the header cells to <TH> in View > Navigation 
Panel > Tags. WCAG-Using table elements. You can also use the Table Editor. For 
complex tables, use header attributes. Level Access-Tagging complex tables 

c. Standards: WCAG 1.3.1 
d. Tags: tables 

3. Data cells are associated with their headers (ex. scope for simple tables, headers and IDs for 
complex tables). 

a. Notes: Check that the headers are properly marked using the Table Editor (Advanced > 
Accessibility > TouchUp Reading Order > Table Editor). 

b. Solution: Use the Table Editor to change headers and structure as necessary. For 
complex tables, use header attributes. Level Access-Tagging complex tables 

c. Standards: WCAG 1.3.1 
d. Tags: tables 

4. If there are merged cells, RowSpan or ColSpan are used appropriately. 
a. Notes: Check that row span and column span are properly marked using the Table Editor 

(Advanced > Accessibility > TouchUp Reading Order > Table Editor). 

https://www.w3.org/TR/WCAG20-TECHS/pdf.html#PDF1
https://www.w3.org/TR/WCAG20-TECHS/pdf.html#PDF1
https://www.w3.org/TR/WCAG21/#non-text-content
https://www.w3.org/WAI/WCAG21/Techniques/general/G111.html
https://www.w3.org/WAI/WCAG21/Techniques/general/G111.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111#use-of-color
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF6.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF6.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF20.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF6.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF20.html
https://www.levelaccess.com/tagging-complex-tables/
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF20.html
https://www.levelaccess.com/tagging-complex-tables/
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF20.html
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b. Solution: If they are not, right click the cell in Table Editor, select “Table Cell Properties”, 
and set the Row Span and/or Column Span attributes as necessary. Tagged PDF-Irregular 
table 

c. Standards: WCAG 1.3.1 
d. Tags: tables 

5. Are data table captions and summaries used where appropriate? 
a. Notes: When necessary to understand the table, captions and summaries clearly 

connected to the table should be used. 
b. Solution: Add descriptive captions and summaries to tables where necessary. 
c. Standards: WCAG 1.3.1 
d. Tags: tables 

Forms 
1. Form input elements have tool tips that identify their purpose and match the associated text 

label. 
a. Notes: The tool tips provide information about the purpose of the form field to assistive 

technology such as screen readers. Check that the tool tip text matches the field’s 
visible text label by going to Tools tab > Prepare Form tool, right clicking a form field, 
and selecting “Properties”. If a field is required, this should be specified in the tool tip. 
WebAIM-Ensure Every Form Field Has a Descriptive Tooltip 

b. Solution: Add or edit the tool tip in “Properties” as necessary. 
c. Standards: WCAG 1.3.1 
d. Tags: forms 

2. Related form elements and elements with multiple labels are grouped appropriately (ex. group 
name identified as part of the tool tip of the element, radio buttons have the same name). 

a. Notes: Check by going to Tools tab > Prepare Form tool, right clicking a form field, and 
selecting “Properties”. Every radio button in the same group should have the same 
name. The tool tip should also be the same for every radio button in the group and 
should include the group name. The “Radio Button Choice” value in the “Options” tab in 
the “Properties” window should match the visible text that appears next to the radio 
button. This allows screen reader and other assistive technology users to be able to 
accurately understand and fill out the form. WebAIM-Ensure Every Form Field Has a 
Descriptive Tooltip 

b. Solution: Edit the “Name”, “Tooltip”, and “Radio Button Choice” values in the 
“Properties” window as necessary. 

c. Standards: WCAG 1.3.1 
d. Tags: forms 

3. Required form elements or form elements that require a specific format, value, or length 
provide this information as a text description. 

a. Notes: Providing this information helps users – especially those with cognitive or visual 
disabilities – more quickly, easily, and accurately complete the form. Include 
information such as date format (“mm/dd/yyyy”), when a question is required 
(“required” rather than an asterisk, which may not be read by a screen reader), and 
character limits. 

https://taggedpdf.com/508-pdf-help-center/irregular-table-span/
https://taggedpdf.com/508-pdf-help-center/irregular-table-span/
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
https://webaim.org/techniques/acrobat/forms#:%7E:text=With%20the%20Prepare%20Form%20tool,it%20if%20it%20does%20not.
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
https://webaim.org/techniques/acrobat/forms#:%7E:text=With%20the%20Prepare%20Form%20tool,it%20if%20it%20does%20not.
https://webaim.org/techniques/acrobat/forms#:%7E:text=With%20the%20Prepare%20Form%20tool,it%20if%20it%20does%20not.
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321#info-and-relationships
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b. Solution: Add information about required form elements and required formats as a text 
description in the tool tip by going to Tools tab > Prepare Form tool, right clicking a form 
field, and selecting “Properties”. 

c. Standards: WCAG 3.3.1; WCAG 3.3.2 
d. Additional resources: WCAG-Providing labels for interactive form controls | WCAG-

Indicating required form controls 
e. Tags: forms 

4. Sufficient labels, cues, and instructions for required interactive elements are provided at the 
beginning of the form or set of fields via instructions, examples, and/or properly positioned 
form labels. 

a. Notes: Related fields need to provide a group name (ex. "Gender: Female"). 
b. Solution: Add or edit written labels and instructions as necessary to be sufficiently 

descriptive. 
c. Standards: WCAG 3.3.2 
d. Additional resources: WCAG-Providing descriptive labels | WCAG-Providing labels for 

interactive form controls | WCAG-Indicating required form controls 
e. Tags: forms 

5. If there are form validation errors, they are presented in an efficient, intuitive, and accessible 
manner. The error is clearly identified. Quick access to the problematic element is provided. The 
user is allowed to easily fix the error and resubmit the form. 

a. Notes: If validation errors are provided, check that they are clear and easy to 
understand, including identifying which field caused the error and what the error is. For 
example: “Invalid date/time: please ensure that the date/time exists. Field [Date you are 
available] should match format mm/dd/yyyy”. 

b. Solution: Edit the validation error messages as necessary using content menu for the 
form control > Properties > Format tab > Format Category > Options. Also specify the 
required format in the “Tooltip” in the “General” tab. WCAG-Indicating when user input 
falls outside required format or values 

c. Standards: WCAG 3.3.1 
d. Tags: forms 

6. If an input error is detected, suggestions are provided for fixing the input in a timely and 
accessible manner. 

a. Notes: If input error messages are provided, they should include information on how to 
fix the error. 

b. Solution: Edit the validation error messages as necessary using content menu for the 
form control > Properties > Format tab > Format Category > Options. Also specify the 
required format in the “Tooltip” in the “General” tab. WCAG-Indicating when user input 
falls outside required format or values 

c. Standards: WCAG 3.3.3 
d. Tags: forms 

Generally not applicable to PDFs 

7. When a user inputs information or interacts with a control, it does NOT result in a substantial 
change to the page, the spawning of a pop-up window, an additional change of keyboard focus, or 

https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322#error-identification
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322#labels-or-instructions
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF10.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF5.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF5.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322#labels-or-instructions
https://www.w3.org/WAI/WCAG21/Techniques/general/G131.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF10.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF10.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF5.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF22.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF22.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322#error-identification
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF22.html
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF22.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C332%2C331#error-suggestion
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any other change that could disorient the user unless the user is informed of the change ahead of 
time. 

a. Notes: This is generally true for PDFs unless custom scripts are used. 
b. Solution: Update the action to occur on form submission (mouse click or keyboard 

activation of an “Enter” or “Submit” button) rather than on input OR inform the user of 
the change ahead of time. Alternatively, remove the custom script altogether. 

c. Standards: WCAG 3.2.2 
d. Additional Resources: WCAG-Providing submit buttons 
e. Tags: forms 

8. If the user can change or delete legal, financial, or test data, the changes/ deletions can be reversed, 
verified, or confirmed 

a. Standards: WCAG 3.3.4 
b. Notes: This is generally not applicable to PDFs unless custom scripts are used. 
c. Solution: Make sure there is verification before a user is able to submit legal, financial, 

or test data, if there is a custom script to enable submission within the document. 
d. Tags: forms 

Time-based Media and Animated Content 
1. Animated content has an alternative or is described in text 

a. Notes: Same procedure as evaluating alt text for images. 
b. Solution: If no or inadequate alt text is provided, describe the content in the text or add 

alt text by going to Tools > Advanced Editing > TouchUp Object Tool > TouchUp 
Properties > Tag > Alternative Text. WCAG-Adding alt text 

c. Standards: WCAG 1.1.1 
d. Tags: time-based media 

2. Automatically moving, blinking, scrolling, or auto-updating content (ex. multimedia, animation, 
dynamic content) that lasts longer than 5 seconds can be paused, stopped, or hidden by the 
user. 

a. Notes: Moving, blinking, and scrolling is okay if it lasts less than 5 seconds or if a 
mechanism is available to pause, stop, or hide the content. (Note that this mechanism 
should also meet accessibility requirements including keyboard accessibility). 

b. Solution: Since PDFs don’t provide a lot of control over animated content, it is best to 
avoid embedding animated content and link to external multimedia if necessary rather 
than embedding it. 

c. Standards: WCAG 2.2.2 
d. Tags: time-based media 

3. If time-based media is present or embedded, it has been reviewed using the Time-Based Media 
worksheet. 

a. Solution: Review embedded or linked multimedia using the HHS Time-Based Media 
worksheet. 

b. Standards: WCAG 1.1.1, WCAG 1.2.# 
c. Tags: time-based media 

4. If there is audio that automatically plays for more than 3 seconds, a mechanism is provided to 
stop, pause, mute, or adjust volume. 

https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322#on-input
https://www.w3.org/WAI/WCAG21/Techniques/pdf/PDF15.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C131%2C132%2C133%2C134%2C142%2C144%2C211%2C212%2C222%2C231%2C242%2C243%2C246%2C247%2C311%2C312%2C321%2C322%2C331%2C332%2C333#error-prevention-legal-financial-data
https://www.w3.org/TR/WCAG20-TECHS/pdf.html#PDF1
https://www.w3.org/TR/WCAG21/#non-text-content
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C222#pause-stop-hide
https://www.w3.org/TR/WCAG21/#non-text-content
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C222#time-based-media
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a. Solution: Since PDFs don’t provide a lot of control over audio content, it is best to avoid 
embedding audio content and link to external multimedia if necessary rather than 
embedding it. 

a. Standards: WCAG 1.4.2 
b. Tags: time-based media 

5. Content (including in embedded videos) does NOT flash more than 3 times per second. 
a. Notes: Flashing more than 3 seconds is permitted if the flashing content is sufficiently 

small (341 x 256 CSS pixels) AND the flashes are of low contrast and do not contain high 
levels of red. Content that flashes more than 3 times per second can trigger seizures. 
WCAG-Tool to ensure flash threshold 

b. Solution: Edit the content to remove or reduce the flashing, reduce the size of the 
content as a proportion of the page, or remove the content. 

c. Standards: WCAG 2.3.1 
d. Tags: time-based media 

 

https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C222#audio-control
https://www.w3.org/WAI/WCAG21/Techniques/general/G15.html
https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=111%2C142%2C222%2C231#three-flashes-or-below-threshold
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